Entradas de Julio del 2006

Debian Testing, Gnome, Firefox, Flash, Esound (esd) y dos horas de mi vida

Jueves 13 de Julio del 2006

Como no puede ser que sólo escriba nOvaZuZu, ya estoy de vuelta con la receta del día…

En vista del post de ayer, alguien podría haber deducido que en el curro me han dado un portatil, y que lo he medio liberado (XP mediante) con Debian Testing… ¡Pues efectivamente! La chuleta de hoy tiene que ver con Debian, o con Gnome, o con Firefox, puede que sea Flash… El caso es que no podía hacer que el Firefox tirase del demonio Esound (esd) para reproducir sonido, por lo que tampoco tenía mezcla de sonido y no podía tener el Xmms y el Video Google sonando al mismo tiempo…

Partimos de una Debian Testing actualizada con el plugin Flash bajado directamente de Macromedia:

  1. Editamos “/etc/firefox/firefoxrc” para que diga “FIREFOX_DSP=esddsp”.
  2. Ejecutamos “strings libflashplayer.so | grep esd” y comprobamos que todo está en su sitio, fundamentalmente:
    1. libesd.so.1
    2. /tmp/.esd/socket

    En mi caso no tengo “libesd.so.1”, así que enlace simbólico al canto… “/usr/lib/libesd.so.1 -> /usr/lib/libesd.so.0”. La parte de “/tmp/.esd/socket” si está en su sitio, pero por lo visto no es así en todas las Ubuntu.

  3. A correr

Qué bien me lo paso afinando configuraciones de equipos recién instalados… o:-)

La bibliografía: No sound in Flash after upgrade to Breezy [Archive] – Ubuntu Forums

Instalando SapGUI 6.40 for Java en Debian

Miércoles 12 de Julio del 2006

Efectivamente, estoy trabajando con SAP en Realtech, y ¡he aprendido algo!

Como la instalación de SapGUI en Debian no inestable tiene truco, aprovecho la entrada en plan receta.

Lo primero es instalar los paquetes Java de Sun. La opción que más me gusta es instalar los paquetes que tenemos en Debian inestable, para ello descargamos los siguientes paquetes:

sun-java5-bin
sun-java5-demo
sun-java5-jdk
sun-java5-jre

y los instalamos a capón con “dpkg -i *.deb”.

Descomprimimos el instalador del SapGUI, y lo instalamos con “java -jar PlatinGUILNX_6.jar”.

Ojo que tenemos que tener instalado el siguiente paquete:

libstdc++2.10-glibc2.2

Ya para terminar, tenemos que editar el script “guilogon” que se usa para lanzar el SapGUI, y añadir la línea:

export LD_LIBRARY_PATH=/opt/SAPClients/SAPGUI6.40rev6/bin

dependiendo de la ruta en la que hayamos instalado el SapGUI.

¡A disfrutarlo, chavales!